Binary String Matching

时间限制:3000 ms  |  内存限制:65535 KB
难度:3
描述
Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit
输入
The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.
输出
For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
样例输入
3
11
1001110110
101
110010010010001
1010
110100010101011
样例输出
3
0
3
来源
网络
上传者
naonao


代码

#include <stdio.h>
int	main(){
	int n,i,j=0,k=0,l=0;
	scanf("%d",&n);
	getchar();
	char a[10];
	char b[1000];
 	for(i=0;i<n;i++){
		scanf("%s",a);
		getchar();
		scanf("%s",b);
		getchar();
		while(b[j]!='\0'){
			while(a[k]!='\0'){
				if(a[k]!=b[j+k]){
				break;
				}
				k++;
				if(a[k]=='\0'){
					l++;
					break;
				}
			}
			j++;
			k=0;	
		} 
		printf("%d\n",l);
		k=0;
		j=0;
		l=0;
 	}	
}

标签: acm, acm, 解题报告